You are here
Home > Topics > Routing >

L3VPN Part 3 of 5

CE-PE: IGP – EIGRP

As in the previous scenario, we will start with configuring EIGRP on the remote sites first. The config is pretty much straightforward

R18
interface Loopback18
ip address 18.18.18.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 172.16.138.2 255.255.255.0
 speed 100
 full-duplex
!
router eigrp 10
 network 18.18.18.0 0.0.0.255
 network 172.16.138.0 0.0.0.255
 no auto-summary
!

R20
interface Loopback20
 ip address 20.20.20.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 172.16.208.2 255.255.255.0
 speed 100
 full-duplex
!
router eigrp 10
 network 20.20.20.0 0.0.0.255
 network 172.16.208.0 0.0.0.255
 no auto-summary
!

Next step is configuring the PEs (PE facing the customer/remote site).

R8
router eigrp 100
 no auto-summary
!
 address-family ipv4 vrf CUSTD100
  redistribute bgp 100 metric 1000 10 255 1 1500
  network 172.16.208.0 0.0.0.255
  no auto-summary
  autonomous-system 10
 exit-address-family
!
router bgp 100
 address-family ipv4 vrf CUSTD100
  redistribute eigrp 10
  no synchronization
  exit-address-family
!

R13
router eigrp 100
 no auto-summary
!
 address-family ipv4 vrf CUSTD222
  redistribute bgp 100 metric 1000 20 255 1 1500
  network 172.16.138.0 0.0.0.255
  auto-summary
  autonomous-system 10
 exit-address-family
!
router bgp 100
 address-family ipv4 vrf CUSTD222
  redistribute eigrp 10
  no synchronization
 exit-address-family
!

At the PE sides, you will need to configure the “address-family” under the EIGRP process and then advertise the network(s) as you normally would. The main thing to notice in the above config snippet is that the EIGRP AS number configured in the ISP router (100 in our case) does not need to match the EIGRP number at the client router (10). The trick is with this command “autonomous-system 10” which actually make things work by matching the AS numbers on both sides. Of course, you will need to redistribute EIGRP process under the corresponding VRF that is configured under the BGP process and redistribute BGP process under the corresponding VRF that is configured under the EIGRP process.

Let’s verify that we have established EIGRP on CE-PE on both ends:

Last step is configuring the ISP PEs (ISP PE facing another ISP PE)

R5:
router bgp 100
!
 address-family ipv4 vrf CUSTC100
neighbor 172.16.153.1 remote-as 500
neighbor 172.16.153.1 activate
neighbor 172.16.153.1 as-override
neighbor 172.16.153.1 soft-reconfiguration inbound
no synchronization
exit-address-family
!

R1:
router bgp 500
!
address-family ipv4 vrf CUSTC500
neighbor 172.16.153.2 remote-as 100
neighbor 172.16.153.2 activate
neighbor 172.16.153.2 as-override
neighbor 172.16.153.2 soft-reconfiguration inbound
no synchronization
exit-address-family
!

R4:
router bgp 500
!
 address-family ipv4 vrf CUSTC500
neighbor 172.16.143.2 remote-as 100
neighbor 172.16.143.2 activate
neighbor 172.16.143.2 as-override
neighbor 172.16.143.2 soft-reconfiguration inbound
no synchronization
exit-address-family
!

R10:
router bgp 100
!
 address-family ipv4 vrf CUSTC222
  neighbor 172.16.143.1 remote-as 500
  neighbor 172.16.143.1 activate
 neighbor 172.16.143.1 soft-reconfiguration inbound
  no synchronization
exit-address-family
!

Both router R18 and R20 are aware of the networks behind each other. Site to site connectivity has been confirmed as shown:

Enter the text or HTML code here

Leave a Reply

Please type the characters of this captcha image in the input box

Please type the characters of this captcha image in the input box

Top