You are here
Home > Topics > Routing >

L3VPN Part 4 of 5

CE-PE: IGP – OSPF

As always, I will start with the remote sites to configure OSPF.

R9
interface Loopback9
 ip address 9.9.9.9 255.255.255.255
!
interface Loopback99
 ip address 99.99.99.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 172.16.89.2 255.255.255.0
 speed 100
 full-duplex
!
router ospf 20
 router-id 9.9.9.9
 log-adjacency-changes
 no auto-cost
 network 99.99.99.0 0.0.0.255 area 0
 network 172.16.89.0 0.0.0.255 area 0
!

R14
interface Loopback14
 ip address 14.14.14.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 172.16.34.2 255.255.255.0
 speed 100
 full-duplex
!
router ospf 20
 network 14.14.14.0 0.0.0.255 area 0
 network 172.16.34.0 0.0.0.255 area 0
!

Next step is configuring the PEs facing the CEs.

R8
router ospf 20 vrf CUSTB100
 redistribute bgp 100 subnets
 network 172.16.89.0 0.0.0.255 area 0
!
router bgp 100
 address-family ipv4 vrf CUSTB100
 redistribute ospf 20 vrf CUSTB100
 no synchronization
 exit-address-family
!

R13
router ospf 20 vrf CUSTB222
 redistribute bgp 100 subnets
 network 172.16.34.0 0.0.0.255 area 0
!
router bgp 100
 address-family ipv4 vrf CUSTB222
 redistribute ospf 20 vrf CUSTB222
 no synchronization
 exit-address-family
!

As you noticed, the command special OSPF VRF command “router ospf process-id vrf” which differs from how EIGRP VRF is configured as we saw in the EIGRP post. Of course, you will need to redistribute OSPF 20 into BGP and vice versa.

Verifying OSPF is established between the PEs and CEs. Note that, unlike EIGRP, there is no VRF-specific OSPF show command:

Final step is to configure ISP PEs facing the other ISP PEs.

R5:
router bgp 100
 address-family ipv4 vrf CUSTB100
  neighbor 172.16.152.1 remote-as 500
  neighbor 172.16.152.1 activate
  neighbor 172.16.152.1 as-override
  neighbor 172.16.152.1 soft-reconfiguration inbound
  no synchronization
 exit-address-family
!

R1:
router bgp 500
 address-family ipv4 vrf CUSTB500
  neighbor 172.16.152.2 remote-as 100
  neighbor 172.16.152.2 activate
  neighbor 172.16.152.2 as-override
  neighbor 172.16.152.2 soft-reconfiguration inbound
  no synchronization
 exit-address-family
!

R4:
router bgp 500
 address-family ipv4 vrf CUSTB500
  neighbor 172.16.142.2 remote-as 100
  neighbor 172.16.142.2 activate
  neighbor 172.16.142.2 as-override
  neighbor 172.16.142.2 soft-reconfiguration inbound
  no synchronization
 exit-address-family
!

R10:
router bgp 100
 address-family ipv4 vrf CUSTB222
  neighbor 172.16.142.1 remote-as 500
  neighbor 172.16.142.1 activate
  neighbor 172.16.142.1 as-override
  neighbor 172.16.142.1 soft-reconfiguration inbound
  no synchronization
exit-address-family
!

Let’s confirm that each remote router is learning the networks behind the other remote router and that site to site connectivity is present:

Enter the text or HTML code here

Leave a Reply

Please type the characters of this captcha image in the input box

Please type the characters of this captcha image in the input box

Top